Ask a Pro
Help! Receiver Won’t Play Video With HDMI Converters
CE pros' receiver won't play video when using certain HDMI to Cat 5/Cat 6 converters.
image
Denon AVR-1910 Receiver
December 01, 2009 by CE Pro

Q. I’ve used Denon receivers for years and never had a problem before. However, the new AVR-1910 (and only this model) has a weird quirk whereas when using either a Key Digital or Spectrum HDMI to Cat 5/Cat 6 converter, (even with only a 50-foot run of dual Cat 6), it will not produce video.

I have spoken directly to both heads of these companies and they are trying to find out what the problem is. They both have also informed me that I’m not the only dealer who has run into or complained about this problem. I only use Liberty wire and connectors, and there are no crimps, bends, or staples in the short wire run.

What is very unusual, I was not able to bring up the Blu-ray player’s menu, (Sony BDP-S360 with their newest software upgrade), but it would play the movie for about 30 seconds and then go blank on both brands’ boxes. I’ve tried two converter boxes from both brands and two AVR-1910s to eliminate the possibility of simply having a defective receiver or converter.

Anyone else out there running into this problem? And if so, has anyone successfully made it work? My best guess is that there’s nothing wrong with the converter boxes that I had on this job site, (because I’ve used them on other jobs with no problems and in my home with my OPPO BDP83 on an older Denon AVR-2808), and the problem is with the AVR-1910. Any suggestions or solutions would be greatly appreciated. - Dave Stevens of Steven’s Audio

A. Shannon Orebaugh of Custom Wiring Concepts added this on the CE Pro Forums:

Have you tried pre-tested (tested with at least a different Denon AVR) converters? Based on Denon confessing to having a problem, your done troubleshooting.

The last time I had converter issues, I pulled a test/temp, CAT6 (same length) between the AVR and display across the floor to eliminate the pre-wired CAT6 cable. That happened to be Component over CAT6 and the job had two TVs. That troubleshooting method proved the problem to be with the TV, since the second TV worked (Vizio worked and the NuVision didn’t. The NuVision was more sensitive to Component level voltages, which were low.

Troubleshooting is nothing more than eliminating variables. Good luck!

Stevens: Been there, done that. The TV is a new 58” Samsung model and its voltage level is right on the money. I truly appreciate the advice & help. Jeff Boccaccio is working on this as we speak. If he can’t solve the problem, then we know not to sell any more AVR-1910s for this type of installation.

Orebaugh: Interesting the TV is a Samsung. The one and only problem I’ve had with a 15m Ethereal HDMI cable was with a Samsung. I’ve since stopped using HDMI cables over 6m. Don’t you love this business? [There’s a] new manufactured problem with every model change.

Stevens: The original HDMI problems with the older Samsung TVs was the handshake between the TV and 1st generation Scientific Atlanta HD cable boxes. Samsung & SA have corrected that problem a year ago. I will not go beyond 4 meters with any HDMI cable, that’s why I use the Spectrum BX170 Cat 5/6 converter boxes. I used to sell the Key Digital piece, but the Spectrum box offers more for less money.

By the way: Marantz A/V receivers also have this problem. It’s no wonder because Denon and Marantz are the same company. However, I can’t stand Marantz because their internal programming menus [aren’t intuitive]. It takes 15 minutes to find what you’re looking for on a Marantz and only 2 minutes (and that’s only if you’ve never done it before) to perform the same system set up on a Denon. 

Follow Electronic House on Facebook and Twitter.
Newsletter Signup
Don't miss a single cool home. Sign up today to receive your FREE weekly e-mail newsletter.
E-mail Address



Topics

Commenting is not available in this weblog entry.